Page 1 of 1

Icom F-60

Posted: Fri Apr 13, 2012 1:43 pm
by neeko
Greetings!

Was recently donated a few F-60's and need to program them.

Unfortunately, it seems that no matter which software I try, I can't seem to get the software to recognize the transceiver since it always gives me the error message "Connected transceiver is not compatible model".

I've tried the CS-F50 rev 2.1 and had a older CS-F50 rev 1.4 to test but none of them worked.

The unit's start with 220XXXX in the serial number so I was hoping 2.1 would work but to no avail.

Am I missing something here?

Any help is greatly appreciated! :lol:

Re: Icom F-60

Posted: Fri Apr 13, 2012 2:36 pm
by Phil
Neeko,

my be suggestion is to contact Icom and see what version they believe would work with it. if they wont help you my next suggestion is to take the to a Icom dealer.

Re: Icom F-60

Posted: Tue Apr 17, 2012 10:00 pm
by Barny
There are about 4 versions of the software, most recent (i think) is 3.1 which is for the F60 with vibrate function. Once you find the correct versions, if works well.